Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
[RÉSOLU] Options d'import des métadonnées
#1
Bonjour,

Après avoir essayé tout ce que j'ai pu, je n'arrive toujours pas à supprimer un titre et une description qui se mettent par défaut dans tous mes imports.
J'ai même été voir dans darktablerc, où je n'ai pas vu mon titre et ma description parasites.
Par contre, j'ai essayé d'y écrire FALSE.
Mais cela n'a rien fait.
Quand je change dans les options d'import, cela marche, mais qu'une seule fois.
Comment corriger ce petit problème ?

Merci
Répondre
#2
Bonjour,

Pas indispensable ici mais toujours bon de préciser la version de darktable utilisée.

Ces données sont gérées par l'éditeur de métadonnées (à droite sur la table lumineuse). Pour un comportement tel que décrit, il y a probablement un pré-réglage activé automatiquement. voir via le menu "hamburger" (les 3 traits horizontaux) de ce module.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#3
(18-01-21, 19:11)nicoauffray a écrit : Bonjour,

Pas indispensable ici mais toujours bon de préciser la version de darktable utilisée.

Ces données sont gérées par l'éditeur de métadonnées (à droite sur la table lumineuse). Pour un comportement tel que décrit, il y a probablement un pré-réglage activé automatiquement. voir via le menu "hamburger" (les 3 traits horizontaux) de ce module.

Bonjour,

Merci pour la réponse.
C'est la version 3.4.0 d'openSUZE pour Xubuntu 20.04 AVEC KDE Neon user édition.
J'ai bien essayé via le hamburger. J'y ai vu 7 préréglages "CC.... " plus un "tous droits réservés".
Alors une fenêtre déroulante pour les droits varie suivant le choix du préréglage.
J'ai essayé en en créant un nouveau. Mais le titre et la description ne peuvent être changés et enregistrés qu'une fois l'import terminé.
Contrairement aux modules de la chambre noire, je n'ai pas vu d'options pour supprimer ou appliquer automatiquement un préréglage.
Si cela restait un problème interne à DT, tant pis.
Mais si je ne rectifie pas titre et description une fois les photos importées et développées,
je retrouve ceux qui sont inscrits d'office dans les métadonnées de mes photos dans digikam, par exemple (et que dans les raw).

Concrètement, j'ai des centaines de photos de faune et de flore à trier.
Aujourd'hui, chaque fois que j'importe une pellicule, j'ai automatiquement le titre "Chardonneret élégant" et la description "Jardin de l'Oïde".
Bien sur, j'ai bien vérifié si cela pouvait venir de digikam ou de gwenview ou de dolphin; mais non.

Une fois compris et averti, cela semble assez logique de ne modifier les métadonnées que des photos importées.
Sauf qu'il n'y a pas des préréglages, mais des postréglages. Wink

Alors, avec la roulette des paramétres de l'éditeur de métadonnées, je coche titre et description "caché".
Solution radicale qui fonctionne.
Répondre
#4
Sauf que ta solution masque le problème mais ne l'enlève pas. De toute façon, le réglage problématique est toujours là. Tu peux poster une capture d'écran des "options d'importation" de la fenêtre d'import d'un dossier (ou d'images ou depuis le boîtier/carte mémoire, selon où tu as le problème) et de l'onglet "importer" des préférences ?

Et d'ailleurs, c'est via quelle fenêtre d'import ton problème (dossier, image, boîtier/carte mémoire) ?
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#5
(19-01-21, 11:05)nicoauffray a écrit : Sauf que ta solution masque le problème mais ne l'enlève pas. De toute façon, le réglage problématique est toujours là. Tu peux poster une capture d'écran des "options d'importation" de la fenêtre d'import d'un dossier (ou d'images ou depuis le boîtier/carte mémoire, selon où tu as le problème) et de l'onglet "importer" des préférences ?

Et d'ailleurs, c'est via quelle fenêtre d'import ton problème (dossier, image, boîtier/carte mémoire) ?


C'est pour les dossiers et les images.










[Image: Essai-import-DT-2.jpg]





[Image: Pr-f-rences-Importer.jpg]
Répondre
#6
(19-01-21, 12:10)zakfm a écrit :
(19-01-21, 11:05)nicoauffray a écrit : Sauf que ta solution masque le problème mais ne l'enlève pas. De toute façon, le réglage problématique est toujours là. Tu peux poster une capture d'écran des "options d'importation" de la fenêtre d'import d'un dossier (ou d'images ou depuis le boîtier/carte mémoire, selon où tu as le problème) et de l'onglet "importer" des préférences ?

Et d'ailleurs, c'est via quelle fenêtre d'import ton problème (dossier, image, boîtier/carte mémoire) ?

C'est pour les dossiers et les images.





[Image: Essai-import-DT-2.jpg]




[Image: Pr-f-rences-Importer.jpg]

Bonjour,

Après avoir encore cherché dans l'éditeur de métadonnées, je vois bien que je peux créer un nouveau préréglage, le supprimer et le modifier.
À l'import, je le choisis et je remplace ainsi le titre et la description qui me sont imposés par défaut.
Sinon, je peux aussi laisser décoché "appliquer des métadonnées lors de l'importation".

Décoché :
[Image: Essai-import-DT-1.jpg]

Coché :
[Image: Essai-import-DT-2.jpg]

Avec un nouveau préréglage :
[Image: Essai-import-DT-3.jpg]

Avec le nouveau préréglage plus le préréglage "tous droits réservés" :
[Image: Essai-import-DT-4.jpg]

Le problème n'est pas vraiment résolu. Mais cela n'est pas trop gênant.

J'attends une confirmation pour le noter [RÉSOLU]
Répondre
#7
Et si tu effaces les données du titre et description, sans importer, et ferme la fenêtre ensuite. Si tu réouvres ? Ou même manip, mais avant de fermer, décocher l’application des métadonnées (donc après avoir effacer les champs) ?
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#8
Merci pour ta réponse.
Avide d'essayer ta solution, j'ouvre DT, l'import d'un dossier.
Et SURPRISE ! Mon dernier préréglage où j'avais effacé le titre et le description agit par défaut.
Ce fut laborieux. Mais si on cherche bien on finit toujours par trouver.
À priori, cela s'est passé en bidouillant dans l'éditeur de métadonnées.

Toujours dans la table lumineuse, mais ce serait un autre sujet :
Les raccourcis clavier avec le W pour l'aperçu ne fonctionnent pas.
Et W fonctionne bien dans la chambre noire.

Encore merci pour le soutien sur ce forum bien sympa et tout le boulot fait pour arriver à ce super logiciel.
Répondre
#9
(20-01-21, 17:33)zakfm a écrit : Merci pour ta réponse.
Avide d'essayer ta solution, j'ouvre DT, l'import d'un dossier.
Et SURPRISE ! Mon dernier préréglage où j'avais effacé le titre et le description agit par défaut.
Ce fut laborieux. Mais si on cherche bien on finit toujours par trouver.
À priori, cela s'est passé en bidouillant dans l'éditeur de métadonnées.

Toujours dans la table lumineuse, mais ce serait un autre sujet :
Les raccourcis clavier avec le W pour l'aperçu ne fonctionnent pas.
Et W fonctionne bien dans la chambre noire.

Encore merci pour le soutien sur ce forum bien sympa et tout le boulot fait pour arriver à ce super logiciel.

Excellent !

Pour le raccourci, ça ne peut être que lié à ta config, donc recherche le mot-clé "aperçu" dans les raccourcis et redéfinis-le.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#10
(20-01-21, 19:50)nicoauffray a écrit :
(20-01-21, 17:33)zakfm a écrit : Merci pour ta réponse.
Avide d'essayer ta solution, j'ouvre DT, l'import d'un dossier.
Et SURPRISE ! Mon dernier préréglage où j'avais effacé le titre et le description agit par défaut.
Ce fut laborieux. Mais si on cherche bien on finit toujours par trouver.
À priori, cela s'est passé en bidouillant dans l'éditeur de métadonnées.

Toujours dans la table lumineuse, mais ce serait un autre sujet :
Les raccourcis clavier avec le W pour l'aperçu ne fonctionnent pas.
Et W fonctionne bien dans la chambre noire.

Encore merci pour le soutien sur ce forum bien sympa et tout le boulot fait pour arriver à ce super logiciel.

Excellent !

Pour le raccourci, ça ne peut être que lié à ta config, donc recherche le mot-clé "aperçu" dans les raccourcis et redéfinis-le.

C'est ce que j'ai essayé en premier, en vain.
Pas grave, c'est juste de la curiosité. Je n'en ai pas vraiment besoin.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)