Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
darktable-chart
#1
Je lance darktable-chart.
Selon la documentation, 10.3. Utilisation de darktable-chart | usermanual | darktable
dans le premier onglet (utilisé pour définir l'image source), j'ouvre une image exportée en format PFM (Lab Portable Float Map format, extension 
.pfm). J'ai obtenu ce format d'image via Table Lumineuse > Format de fichier = PFM (flottant).

Mais voilà, quand l'ouvre ce document, aucune image n'apparait. Seulement un fond noir.
Qu'est-ce que je fais de "mal"?

[Image: Fond-Noir.jpg]

Je trouve, sur https://pixls.us/articles/profiling-a-ca...ble-chart/ un article qui traite de l'utilisation de darktable-chart.
Il est dit que l'espace couleur de Sortie doit être réglé sur Lab. Or, ce n'est pas mon cas...
Il est dit aussi que je dois changer cette option dans la configuration de darktable via la ligne de commande suivante :

> darktable --conf allow_lab_output=true

Rien de visible à ce sujet dans les Préférences...

L'auteur dit aussi que je pourrais changer le fichier "darktablerc"?

~/.config/darktable/darktablerc
allow_lab_output=TRUE

Je suis sur Windows. Je ne trouve pas de répertoire "config" nul part.

Ah! Je pense que j'ai trouvé le fichier dans C:\Users\roger\AppData\Local\darktable.
J'ouvre le fichier avec Bloc-Notes et j'ajoute la ligne "allow_lab_output=TRUE" et je sauvegarde.
Je redémarre le logiciel.
Je réouvre mon image de ColorChecker.
Je me dirige dans le module Profil de Sortie.
Hélas! L'option Lab n'apparait pas dans la liste:


[Image: Profile-de-sortie.jpg]

Victoire! L'espace Lab est maintenant disponible.
J'ai ré-ouvert le fichier darktablerc et "allow_lab_output" était à "false"?
J'ai changé pour "TRUE". J'ai sauvegardé. J'ai relancé dakrtable et voilà!
[Image: Profile-de-sortie-2.jpg]

J'ai ré-exporté mon image en PFM et j'ai tenté de l'outil dans darktable-chart mais, hélas, à l'ouverture, j'ai reçu le message d'erreur Windows suivant:

[Image: chart-crash.jpg]

Peut-être que mon fichier PDF est trop "gros"?
Ça me fait un fichier de 426 MégaOctets?
Je devrais peut-être réduire la résolution...

Victoire! L'image est visible!
Je n'avais pas réglé le Profil sur Lab dans les Options d'enregistrement.
Ce n'était pas suffisant de choisir Lab dans la Chambre Noire > Profil de Sortie (il faut croire).
En passant, il n'y a pas d'options pour changer la résolution?
Alors, j'ai essayé une réduction de 25% mais ça n'a aucun effet sur la taille du fichier?
[Image: Profile-de-sortie-3.jpg]

Voici l'affichage résultant sans le fichier *.cht.

[Image: Affichage-SANS-cht.jpg]

Voici l'affichage AVEC le fichier *.cht sélectionné :
[Image: Affichage-AVEC-cht.jpg]

Il me reste à trouver mon fichier de référence qui n'est autre que les mesures CIE Lab/XYZ/spectrales des 24 pavés de la mire.

On progresse...

Évidemment, je bute sur le format de fichier "CIE/IT8".
J'ai fait plusieurs tentatives... mais ça ne marche pas?
Voici le contenu du fichier de mesure :

LGOROWLENGTH 12
ORIGINATOR "ColorChecker24"
MANUFACTURER "X-Rite - http://www.xrite.com"
1/12/2021 # Time: 14:33
NUMBER_OF_FIELDS 5
BEGIN_DATA_FORMAT
SAMPLE_ID SAMPLE_NAME LAB_L LAB_A LAB_B
END_DATA_FORMAT
NUMBER_OF_SETS 24
BEGIN_DATA
1 A1 37.7976 14.9189 14.6098
2 A2 62.0301 34.0401 58.7391
3 A3 27.9205 17.0872 -48.6711
4 A4 94.0586 -1.0418 2.8835
5 B1 65.7762 16.4541 17.9442
6 B2 39.6608 8.6631 -43.1892
7 B3 53.4247 -39.6051 30.6583
8 B4 79.4438 -0.6685 0.8970
9 C1 49.7737 -3.9058 -22.8392
10 C2 51.6068 46.4659 16.6463
11 C3 42.0179 56.2369 28.2988
12 C4 64.5995 0.1260 0.2165
13 D1 42.3360 -14.2769 20.0762
14 D2 30.2330 21.9605 -20.0066
15 D3 81.3347 3.9422 76.8753
16 D4 50.5762 -0.9491 0.0959
17 E1 55.3149 8.0885 -24.4423
18 E2 71.3812 -23.8552 57.4252
19 E3 51.3893 50.5470 -12.8133
20 E4 35.2206 -0.8911 -0.4628
21 F1 70.2999 -32.9363 0.1569
22 F2 71.4357 19.0178 66.6829
23 F3 48.6209 -27.7380 -27.5854
24 F4 21.4371 0.1309 -0.9290
END_DATA
Répondre
#2
Je t'ai répondu : https://forums.darktable.fr/showthread.p...7#pid47077
Répondre
#3
L'outil darktable-chart produit des LUT appliquées en Lab avec une courbe de base RGB. C'est un outil plutôt mauvais et surtout dépendant de l'exposition originale de la photo.
Aurélien, photographe portraitiste, spécialiste calcul.
Développeur de filmique, égaliseur de tons, balance couleur, etc.
darktable est mon métier, pensez à m'aider :
[Image: 2FAd4rc]
Répondre
#4
Merci pour ton avis Aurélien, c'est aussi ce que je pensais. Je n'ai pas été très satisfait de ce que j'obtenais avec les HaldCLut !
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)