Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Régression de reconnaissance d'un objectif
#1
Bonjour,
je constate une régression dans la reconnaissance des mon objectif Tamron 100-400 mm.
Lors de l’achat l’objectif utilisé à l’époque avec un D610 il n’était pas reconnu j’ai créé un fichier LCP avec adobe-dng-converter et uploadé des photos à lensfun pour créer un profil mais comme il n’apparaissait pas dans les exif j’ai remonté l’information sur le site d’exiv2 .Robin mills a fourni une solution qui consistait a créer un fichier .exiv2 à la racine de mon /home pour régler le problème
https://dev.exiv2.org/issues/1355
Depuis j’ai remplacé mon D610 par un Z6 avec la bague FTZ le zoom est maintenant dans la base de données de lensfun et avec les dernières versions d’exiv2 je n’avais plus besoin du fichier lcp ni du fichier .exiv2 l’objectif était reconnu automatiquement sauf que dernièrement pour les photos nouvellement importées l’objectif n’est plus reconnu, je peux tout de même le sélectionner manuellement puisqu’il est dans la base de données lensfun en recréant le fichier .exiv2 il est de nouveau reconnu
Donc ça fonctionne comme ça mais si quelqu’un a un début d’explication pour expliquer pourquoi je suis de nouveau obligé de repasser par ce fichier pour que l’objectif et uniquement celui-ci soit reconnu je suis preneur.

Le fichier .exiv2:
https://hidrive.ionos.com/lnk/p1k1I8JH
les informations de l'image sans .exiv2:
https://hidrive.ionos.com/lnk/WNk1ozNB
les informations de l'image avec .exiv2:
https://hidrive.ionos.com/lnk/l9kVozCr
Répondre
#2
Bonjour,
Quelle version d'exiv2?
Un raw avec l'objectif permettrait de faire des essais.
Cdlt
Répondre
#3
la version d'exiv2 est 0.27.5
le raw :
https://hidrive.ionos.com/lnk/ycEVIMcA
Répondre
#4
Même version, même comportement chez moi.
Le champ classique "lens model" n'est pas non plus renseigné par l'APN, peut-être lié a la bague?.

[Image: exiv2.png]


Exiftool joue à la devinette.


[Image: exiftool.png]

Bon tu as une solution Cool 

Cordialement.
Répondre
#5
Peut être un problème exiv2, avec les anciennes photos prise sans bague avec le D610 l'objectif n'est plus reconnu sans ce fichier .exiv2.
avec la bague Ftz et un objectif sigma 105mm tout est reconnu automatiquement.
Effectivement j'ai une solution ,je cherchais juste à comprendre.
Répondre
#6
(10-01-23, 15:38)ctouze a écrit : Peut être un problème exiv2, avec les anciennes photos prise sans bague avec le D610 l'objectif n'est plus reconnu sans ce fichier .exiv2.
avec la bague Ftz et un objectif sigma 105mm tout est reconnu automatiquement.
Effectivement j'ai une solution ,je cherchais juste à comprendre.

Bonjour,
Non le comportement n'a pas changé, il te faut effectivement ce fichier .exiv2 à la racine de ton /home.
Code :
[nikon]
204=Tamron 100-400mm F/4.5-6.3 Di VC USD
Par contre il faut savoir que cette reconnaissance d'objectif ne se fera qu'à l'importation de l'image dans la base de donnée dt et dès cet instant il te faut ce fichier.
De la table lumineuse, va dans images sélectionnées puis enlever.
Réimporte l'image en question, ton objectif devrait-être reconnu avec ~/.exiv2 présent.

[Image: Capture-d-cran-2023-01-25-00-01-55.png]
Répondre
#7
Bonjour,
Merci pour les précisions,effectivement quand je réimporte avec ~/.exiv2 ça fonctionne.
ce que je ne comprend pas c'est pourquoi il faut ce fichier pour cet objectif et pas pour les autre mais la réponse est peut être
dans ce que m'avait répondu Robin Mills : "We're not plan to update the C++ lens recognition code for this lens."
Répondre
#8
Bonjour,
A mon humble avis, il n'y a pas eu de régression, le fichier .exiv2  devait être toujours présent.
Il n'y pas dans les exif de champs renseignant le nom de l'optique et c'est le problème, seul l'Idnumber = 204. (d'ou l'ajout d'info dans le fichier .exiv2)
Exiftool n'identifie pas non plus cette optique bien que dans la liste  cf  https://exiftool.org/TagNames/Nikon.html  "Nikon LensID Values" valeur attendue CC 44 68 98 34 41 DF 0E,
valeur trouvée CC 44 68 98 34 41 DF 4E. Le problème pour moi, sont des exifs mal renseignés par l'apn pour cette optique.
Cordialement
Répondre
#9
J'avais bien effacé le fichier .exiv2 de mon home.
Lens ID : Unknown (CC 44 68 98 34 41 DF 4E) > que ce soit avec les fichiers du D610 ou du Z6.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)