Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: GegeL[Résolu] Installation darktable 2.7 sous Debian Buster
#1
Bonsoir à tous,

Ce soir, j'ai voulu installer le version 2.7.0~git1709 à la place de la version 2.7.0~git1676 sur ma Debian Buster.
Et là, problème de dépendance de la bibliothèque libc6 qui doit être en version >= à 2.29 pour pouvoir installer darktable 2.7.0~git1709.

La version actuelle de libc6 sur debian buster est 2.28-10 et pour avoir la version 2.29 il faut installer le paquet du dépôt sid.
N'ayant pas envie de casser mon système, libc6 est quand même une bibliothèque centrale utilisée par pratiquement tous les programmes, j'ai passer mon tour.


J'ai donc réinstallé la version 2.7.0~git1676 et tous va bien.

Mais, question: qu'en sera t'il de la version 2.8 ou 3.0 que le père noël vas nous apporter ? Sera t'elle compatible avec la/les versions des bibliothèques actuelles de Debian Buster et dérivées ?

Merci pour vos réponses.

Bien cordialement.
NIKON D7200
Nikon AF-P DX Nikkor 70-300mm f/4.5-6.3G ED VR
Sigma 17-70mm F2.8-4 DC MACRO OS HSM Contemporary
Nikon AF-S DX Nikkor 35mm f/1.8G

Debian GNU/Linux 10 Buster / Gnome-Shell
Darktable 2.7 git/master
Répondre
#2
Je suis aussi intéressé par les réponses à venir ...
Lille. Hauts de France
Linux : Distribution Solus Budgie :  https://getsol.us/download/
Site web : http://www.philippedeletree.fr
Youtube : Darktable
Répondre
#3
Pour ce qui en est de la futur, je ne sais pas. Pour lidc6, est ce qu'un

Code :
apt-get -t sid install lidc6

n'aurait pas fait l'affaire (il me semble qu'il y a moyen de forcer l'installation d'un paquet de cette façon)

/!\ écrit de mémoire et je ne suis pas spécialiste de la ligne de commande, vérifier avant d'appliquer merci Wink 
---------------------
Débian 9 Stretch - CPU Intel I3, Radéon HD 4870, SSD 128 Go + HDD1 To + HDD 2To dédié aux photos
darktable 2.6.2
---------------------
Éternel débutant  Shy
Répondre
#4
La prochaine version de Noël sera une 3.0. Et cette 3.0 ne sera rien d'autre que l'actuelle 2.7.0 avec les fonctionnalités, corrections de bugs qui vont intervenir d'ici là (la "feature freeze" ou gel des nouvelles fonctionnalités est prévue pour la fin du mois). En bref, si tu compiles la version master, tu compileras la 3.0.
Aussi appelé Nilvus !
Ubuntu 19.04 - darktable master - Macbook pro fin 2013 13"
Répondre
#5
Bonjour à tous,

Tout d’abord, merci pour vos réponses.

@Roger: c'est justement ce que je ne veux faire pour le moment pour éviter de casser la version stable. Je testerais ultérieurement sur une machine virtuelle.

@nicoauffray: si je comprends bien, cela veut dire que concernant une distribution Debian, il faut installer la version sid puisque la bibliothèque libc6 en version 2.29 n'est disponible que dans cette version et donc qu'un utilisateur, disons lambda, qui utilise actuellement DT 2.6.2 sur une Debian stable Buster ne pourra pas mettre à jour DT en version 3.0 lorsqu'elle sera disponible.

Je pense qu'il y a là un problème. Je veux dire par là que j'ai du mal à penser que DT 3.0 ne sera utilisable que sur une Debian sid qui est une version Debian pour utilisateurs très avertis. Ce n'est pas la version utilisée par monsieur tous le monde.

Précision utile: la version de DT qui concerne ce sujet est le paquet Debian Next "darktable_2.7.0~git1709.580bf49da_amd64.deb" téléchargé à cette adresse https://software.opensuse.org/download.h...=darktable

Bien cordialement.
NIKON D7200
Nikon AF-P DX Nikkor 70-300mm f/4.5-6.3G ED VR
Sigma 17-70mm F2.8-4 DC MACRO OS HSM Contemporary
Nikon AF-S DX Nikkor 35mm f/1.8G

Debian GNU/Linux 10 Buster / Gnome-Shell
Darktable 2.7 git/master
Répondre
#6
(14-09-19, 11:14)GegeL a écrit : Bonjour à tous,

Tout d’abord, merci pour vos réponses.

@Roger: c'est justement ce que je ne veux faire pour le moment pour éviter de casser la version stable. Je testerais ultérieurement sur une machine virtuelle.

@nicoauffray: si je comprends bien, cela veut dire que concernant une distribution Debian, il faut installer la version sid puisque la bibliothèque libc6 en version 2.29 n'est disponible que dans cette version et donc qu'un utilisateur, disons lambda, qui utilise actuellement DT 2.6.2 sur une Debian stable Buster ne pourra pas mettre à jour DT en version 3.0 lorsqu'elle sera disponible.

Je pense qu'il y a là un problème. Je veux dire par là que j'ai du mal à penser que DT 3.0 ne sera utilisable que sur une Debian sid qui est une version Debian pour utilisateurs très avertis. Ce n'est pas la version utilisée par monsieur tous le monde.

Précision utile: la version de DT qui concerne ce sujet est le paquet Debian Next "darktable_2.7.0~git1709.580bf49da_amd64.deb" téléchargé à cette adresse https://software.opensuse.org/download.h...=darktable

Bien cordialement.

Euh dans ce détail là, j'en sais rien. Je suis sur Ubuntu et ne suit pas Debian. Ce que je dis juste est que si on arrive à compiler la master actuelle sur son système, la 3.0 se compilera aussi normalement sans problème puisque la 3.0 ne sera que la version master actuelle finalisée. Pour le reste de tes questions, seul un utilisateur Debian pourrait te répondre. Notre cher et dévoué @pascal par exemple (au passage, il est je crois sur Debian Sid et c'est lui qui intègre (après test) les propositions des développeurs).
Aussi appelé Nilvus !
Ubuntu 19.04 - darktable master - Macbook pro fin 2013 13"
Répondre
#7
Merci pour la réponse,

Je vais compiler la branche master et si ça fonctionne, nul doute qu'il y a un problème avec le paquet DT master du dépôt opensuse.

Effectivement, l'avis de @pascal serait très intéressant.
NIKON D7200
Nikon AF-P DX Nikkor 70-300mm f/4.5-6.3G ED VR
Sigma 17-70mm F2.8-4 DC MACRO OS HSM Contemporary
Nikon AF-S DX Nikkor 35mm f/1.8G

Debian GNU/Linux 10 Buster / Gnome-Shell
Darktable 2.7 git/master
Répondre
#8
Bon, je viens de compiler et d'installer la version master de DT.

Tout c'est bien passer et DT fonctionne parfaitement bien  Smile .
Nul besoin de la version 2.29 de libc6.

Merci @nicoauffray pour sa remarque qui m'a orientée vers la compilation:
> Ce que je dis juste est que si on arrive à compiler la master actuelle sur son système, la 3.0 se compilera aussi normalement sans problème puisque la 3.0 ne sera que la version master actuelle finalisée.

Je passe donc ce sujet en résolu.
NIKON D7200
Nikon AF-P DX Nikkor 70-300mm f/4.5-6.3G ED VR
Sigma 17-70mm F2.8-4 DC MACRO OS HSM Contemporary
Nikon AF-S DX Nikkor 35mm f/1.8G

Debian GNU/Linux 10 Buster / Gnome-Shell
Darktable 2.7 git/master
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)