Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
adaptation chromatique par défaut moderne vs originel - Récup htes lum [Résolu]
#1
Bonjour,

Avec les modules chargés par défaut par l'adaptation chromatique sur "moderne", je suis incapable de récupérer les hautes lumières.

Avec le curseur "exposition relative du blanc" de l'onglet "scène" impossible de récupérer les hautes lumières de l'image et même plus en déplaçant le curseur sur la droite un artefact cyan apparait.
La récupération des hautes lumières me semble impossible.
Je n'ai pas trouvé de solution avec aucun des modules "calibration des couleurs", "filmique", "exposition" et "égaliseur de ton".

Par contre en supprimant les pts 8, 9, 10, "calibration des couleurs", "filmique", "exposition" et avec les 2 manip suivantes
  • Compresser l'historique à partir du point 7 "reconstruire hautes lumières"
  • Réprendre le module "balance des blancs"  "choisir la balance des blancs du boîtier"
  • Ajouter le module filmique > les hautes lumières sont en partie récupérées avec les paramètre par défaut.

Il suffit d'un petite retouche avec le curseur "exposition relative du blanc" de l'onglet "scène" pour obtenir un résultat très correct.

Quelqu'un a-t-il une explication pour obtenir le même résultat sans supprimer les modules ajoutés par l'adaptation chromatique sur "moderne" ?

La photo est disponible sur ce site : https://www.signatureedits.com/free-raw-photos/

Répondre
#2
Ma proposition, filmic - calibration - egaliseur de contraste - balance de couleur -reduction bruit
[Image: DSC-0144-01.jpg]
Répondre
#3
(09-01-21, 21:01)blueberry38 a écrit : Ma proposition, filmic - calibration - egaliseur de contraste - balance de couleur -reduction bruit
[Image: DSC-0144-01.jpg]

Merci, mais ce n'est pas une autre interprétation que je recherche.

Mon questionnement : Existe-t-il un moyen d'obtenir la récupération des hautes lumières comme dans la seconde partie de la vidéo mais sans supprimer les modules proposés par défaut par le réglage  "appliquer l'adaptation chromatique par défaut" réglée sur "moderne"  ?

Personnellement je n'y arrive pas  sans les supprimer.
Répondre
#4
Il faut peut-être désactiver le module 'reconstruction hautes lumières'. Dans le manuel sur darktable.org (en anglais) ils disent que ce module peut interférer avec la reconstruction des hautes lumières dans filmique (par exemple "Highlight Reconstruction, chapitre Module Reference/Processing Modules). Et je l'ai lu aussi ailleurs. Je me rappelle plus si Aurélien le mentionne dans une de ses vidéos. En tout cas, chez moi l'artéfact cyan dans ta photo n'apparait plus et je peux bouger le curseur 'exposition relative du blanc' ou je veux.

Christian
Mes photos ici
Répondre
#5
Hello,
Le module reconstruire les hautes lumières permet ici de récupérer le rouge un peu cramé.
avant
[Image: hautelum1.jpg]
après
[Image: hautelum2.jpg]

belle photo.
Cordialement
Répondre
#6
Smile 
(10-01-21, 01:07)ChristianP a écrit : Il faut peut-être désactiver le module 'reconstruction hautes lumières'. Dans le manuel sur darktable.org (en anglais) ils disent que ce module peut interférer avec la reconstruction des hautes lumières dans filmique (par exemple "Highlight Reconstruction, chapitre Module Reference/Processing Modules). Et je l'ai lu aussi ailleurs. Je me rappelle plus si Aurélien le mentionne dans une de ses vidéos. En tout cas, chez moi l'artéfact cyan dans ta photo n'apparait plus et je peux bouger le curseur 'exposition relative du blanc' ou je veux.

Christian

RESOLU Smile 

Merci Christian

En 12 j'ai désactivé le module "reconstruction des hautes lumières" et le résultat est instantanément correct.

Je dois dire que c'est subtilement écrit dans la doc
Citation :highlights clipping
These controls allow you to choose which areas of the image are impacted by the highlight reconstruction algorithms.
threshold Any pixels brighter than this threshold will be affected by the reconstruction algorithm. The units are in EV, and are relative to the white point set in the scene tab. By default, this control is set to +3 EV, meaning that pixels need to be at least +3 EV brighter than the white point set in the scene tab in order for the highlight reconstruction to have any effect. In practise, this means that highlight reconstruction is effectively disabled by default (for performance reasons it should only be enabled when required). Therefore, to use the filmic rgb highlights reconstruction feature, first click the display highlight reconstruction mask icon to show the mask, and lower this threshold until the highlight areas you want to reconstruct are selected in white by the mask. It may be useful to first review the image using the raw overexposed warning to show you which pixels in the raw file have been clipped, and whether those pixels are clipped on just one RGB channel or all of them.

Il faudrait peut-être ajouter une case à cocher dans l'onglet "reconstruire" de "filmique" pour désactiver le module "reconstruction des hautes lumières".

Mais bon : "Mieux vaut un qui sait que moi qui cherche" Huh .

RESOLU (je sais jamais où le mettre ce) RESOLU
Répondre
#7
(10-01-21, 10:18)stansz a écrit : Il faudrait peut-être ajouter une case à cocher dans l'onglet "reconstruire" de "filmique" pour désactiver le module "reconstruction des hautes lumières".

Ce n'est pas aussi simple. Dans certains cas, le module "reconstruction des hautes lumières" s'associe très bien à l'onglet idoine du module "filmique". Le mieux est simplement de savoir que parfois les 2 ensemble ne font pas bon ménage et dans d'autres cas, ils peuvent même "s'adorer". Ces 2 modules ne travaillent pas tout à fait de la même manière, parfois ça se chevauche (et bonjour les dégâts) parfois ça se complète. Et parfois, l'un est mieux que l'autre.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#8
(10-01-21, 10:29)nicoauffray a écrit :
(10-01-21, 10:18)stansz a écrit : Il faudrait peut-être ajouter une case à cocher dans l'onglet "reconstruire" de "filmique" pour désactiver le module "reconstruction des hautes lumières".

Ce n'est pas aussi simple. Dans certains cas, le module "reconstruction des hautes lumières" s'associe très bien à l'onglet idoine du module "filmique". Le mieux est simplement de savoir que parfois les 2 ensemble ne font pas bon ménage et dans d'autres cas, ils peuvent même "s'adorer". Ces 2 modules ne travaillent pas tout à fait de la même manière, parfois ça se chevauche (et bonjour les dégâts) parfois ça se complète. Et parfois, l'un est mieux que l'autre.

Ok merci pour l'explication, j'ajouterai donc 2 variables booléennes mais dans ma tête. Wink
Répondre
#9
(10-01-21, 11:07)stansz a écrit : Ok merci pour l'explication, j'ajouterai donc 2 variables booléennes mais dans ma tête. Wink

Avec plaisir.

Et au fait, pour le RESOLU, tu édites ton post initial du sujet pour avoir accès à l'édition du titre du sujet. Tu ajoutes (au début ou à la fin, peu importe) le mot résolu (entre crochets, donc [Résolu]).
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#10
Salut,

je viens d'essayer vite fait, pas en adoptant le mode moderne mais en activant la calibration des couleurs avec le 1er Bradford, aucune incompatibilité avec le module reconstruction des htes lumières, à 0,858 environ le cramé central disparait.

Belle photo.

Cdlt
Cordialement
François


EOS 1Ds, 7D, #M42, FujiX20, W10 64 fam
Flickr

[Image: 3411.jpg]

Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 2 visiteur(s)