Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Problème d'affichage dans certains conteneurs
#1
darktable 3.4.1
Linux Mint 20.1 Cinnamon
CG NVidia GeForce GT 1030


Bonjour à tou.te.s

Retour à darktable après plusieurs mois : découverte de filmique, du nouvel agencement des modules, etc. Que du bon !

Mais je reviens vers vous pour quelque chose qui, au premier abord, ressemble plutôt à un bug d'affichage mais je voudrai m'assurer de n'avoir pas oublié quelque chose avant de porter l'éventuel défaut sur github.

Quelques conteneurs de saisie sont affectés d'un défaut d'affichage qui n'entrave pas le bon fonctionnement de darktable mais qui est assez désagréable à l'usage. Cela ne concerne que quelques éléments de la boîte de dialogue "Préférences" et le module "éditeur de métadonnées" de la table lumineuse. Je n'en ai pas trouvé ailleurs pour l'instant. 
Plutôt que de me lancer dans une indigeste description du défaut, voici quelques copies d'écran :

[Image: captur12.png]

[Image: captur11.png]

[Image: captur10.png]

En résumé, on aperçoit dans le conteneur une image figée  de ce qui se trouvait à l'écran au moment de son ouverture. 

Ce phénomène est-il connu ? Si oui, y a-t-il un moyen de le corriger ?
Thierry
Répondre
#2
Désolé, je n'ai jamais eu ce problème ni avec le version 3.4.1 et la master.. Je suis sous OpenSuse Tumbelweed.
Répondre
#3
(19-04-21, 14:24)Yadutaf a écrit : En résumé, on aperçoit dans le conteneur une image figée  de ce qui se trouvait à l'écran au moment de son ouverture. 

Ce phénomène est-il connu ? Si oui, y a-t-il un moyen de le corriger ?

Jamais eu ni jamais vu ce problème. Et franchement, même si tu le vois sur darktable, je doute que ce soit un bug issu directement de darktable. On aurait déjà eu au moins un rapport de ce bug sinon tellement il est énorme et visible. Et je suis régulièrement le github de darktable (contribuant notamment à l'interface de darktable) et aussi le forum anglophone pixl.us.

Bref, je partirais plutôt sur un problème lié à ton affichage ou pilote de carte graphique.

Peux-tu préciser les éléments suivants :

Serveur graphique utilisé : Wayland ou X.org ?
Environnement de bureau : KDE, Gnome, Xfce, autre (préciser) ?
Pilote de ta carte graphique Nvidia et version ?
OpenCL activé ? Si oui, peux-tu vérifier si tu reproduis le problème en désactivant l'OpenCL dans les préférences de darktable. Sinon, bah l'activer pour vérifier si tu reproduis.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#4
Il est sous Mint avec Cinnamon : un dérivé de Gnome 2.
Répondre
#5
(19-04-21, 16:28)jpg54 a écrit : Il est sous Mint avec Cinnamon : un dérivé de Gnome 2.

Même en indiquant Cinnamon, on peut toujours installer ensuite un autre environnement de bureau. Et ça ne donne de toute façon que peu d'infos par rapport à celles demandées.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#6
J'ai juste précisé ce qui a présenté dans le début du post :
<darktable 3.4.1
Linux Mint 20.1 Cinnamon
CG NVidia GeForce GT 1030>
et bien sûr il peut installé un autre environnement.
Répondre
#7
Merci de vous intéresser à la question.

Je suis bien sous Cinnamon, l'OS est à jour.
Le serveur graphique est X.org.
Le driver utilisé est le NVidia 450.102.04.
OpenCL est activé. Le désactiver ne change rien.

Je précise que je n’aperçois ce phénomène que sous darktable et que cela fait déjà plusieurs mois. Cela ne date pas des dernières mises à jours du logiciel ou du système. Dans mon souvenir, cela ne le faisait pas sous 3.2.
Thierry
Répondre
#8
(19-04-21, 19:43)Yadutaf a écrit : Merci de vous intéresser à la question.

Je suis bien sous Cinnamon, l'OS est à jour.
Le serveur graphique est X.org.
Le driver utilisé est le NVidia 450.102.04.
OpenCL est activé. Le désactiver ne change rien.

Je précise que je n’aperçois ce phénomène que sous darktable et que cela fait déjà plusieurs mois. Cela ne date pas des dernières mises à jours du logiciel ou du système.  Dans mon souvenir, cela ne le faisait pas sous 3.2.

J'utilise darktable sous Ubuntu (dont Mint est issu) et n'ai jamais eu de problème. Pas plus sous 3.2 qu'avant ou encore aujourd'hui sur master. Et j'utilise aussi une carte Nvidia. Peut-être que c'est lié à Cinnamon. Je ne sais pas s'il y a des utilisateurs Cinnamon ici qui pourraient confirmer ou infirmer s'ils reproduisent.Sinon, tu peux toujours poster sur Github. Pense à préciser toutes les infos de ce sujet.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#9
> Il est sous Mint avec Cinnamon : un dérivé de Gnome 2.

Probablement le problème alors. Pas certain que Gnome 2 supporte bien tous les attributs CSS que dt utilise (un problème de transparence?). Je pense qu'il faut laisser mourir Gnome 2 tranquillement à ce stade, s'attacher au passé de la sorte n'est pas très bon à long terme de toutes façons.
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#10
(19-04-21, 16:28)jpg54 a écrit : Il est sous Mint avec Cinnamon : un dérivé de Gnome 2.

Petite erreur jpg : 
c'est MATE qui est un fork de GNOME 2. 
Cinnamon est bien un fork de GNOME Shell.
Thierry
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 2 visiteur(s)