Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: mimi85lensfun reconnaissance objectifs
#61
3402 a écrit :Pour mettre la version 0.3.x de lensfun, il faut faire quoi de pas trop compliqué pour un débutant Linux. Merci

Tu peux télécharger les paquets liblensfun-data-v1_0.3.2-3_all.deb et celui de liblensfun1 (0.3.2-3) correspondant à ton architecture (32 ou 64 bits)  et les installer avec un
Code :
sudo dpkg -i paquet.deb
en commençant par liblensfun-data-v1 puis liblensfun1 selon ton architecture machine (cf.
Code :
arch
).

Les deux versions seront installées, mais DT du ppa pmjdebruijn est linké avec/s'appuie sur la 0.2.8 et dès que tu l'auras virée par un
Code :
sudo dpkg -r --force-all liblensfun0 liblensfun-data
, tu n'auras simplement plus de module de correction d'objectif dans DT...

La solution est alors de créer un lien (un "raccourci") pour faire en sorte que ce soit la 0.3.2 de lensfun qui soit prise en compte, via un :

Code :
sudo ln -s /usr/lib/x86_64-linux-gnu/liblensfun.so.0.3.2 liblensfun.so.0

Mais ! Si ton architecture n'est pas 64 bits, tu devras d'abord trouver où est précisément liblensfun.so.0.3.2 via un
Code :
sudo dpkg -L liblensfun1 | grep liblensfun.so.0.3.2
et donc remplacer le chemin complet de cette librairie par celui indiqué par la commande dans le
Code :
ln -s
.

Dans tous les cas, tu peux re-installer la 0.2.8 via un sudo dpkg -i liblensfun0 liblensfun-data`.

Et pour la suite, notamment les mises à jour de lensfun, j'avoue que j'ai pas regardé mais celles de la 0.3.2 ne se feront pas automatiquement, tant que 16.10 n'est pas sortie.
Ubuntu 18.04 + dt 2.6 & Pentax K5 & K3-II + cailloux Pentax et Sigma

Répondre
#62
Bon, je fatigue et peux pas modifier mon précédent post... :-(

Code :
sudo apt-get install liblensfun0 liblensfun-data

pour re-installer la version 0.2.8 pour le moment.
Ubuntu 18.04 + dt 2.6 & Pentax K5 & K3-II + cailloux Pentax et Sigma

Répondre
#63
Ce qui veux dire qu'avec mon opensuse où le paquet liblensfun1 est installé, ça devrait fonctionner !?

Qui peux me passer un fichier lcp converti en xml pour que je fasse un essai ? Faut, soit qu'il corresponde à un de mes objectifs, soit me fournir un raw pris avec l'objectif correspondant au fichier.

Merci d'avance !

Mes objectifs non reconnus ou partiellement reconnus :
  • Nikon AF Nikkor 24mm f/2.8D : distorsion seulement
  • Nikon AF-S VR Zoom-Nikkor 70-200mm f/2.8G IF-ED : distorsion seulement (celui que je suis en train de caractériser)
  • Sigma 85mm F1.4 EX DG HSM : rien
 
Mes photos : jpverrue.fr
Répondre
#64
@manu Merci de ton aide, une erreur de dépendance a viré la correction d'objectifs de DT.

J'ai pas tout compris, quand je fais <arch>, la réponse est x86_64, mais j'ai trouvé liblensfun.so.0.3.2 dans /usr/lib/i386-linux-gnu/liblensfun.so.0.3.2 et non pas dans /usr/lib/x86_64-linux-gnu. Cependant je suis bien en 64bits, et tout ce que j'ai sur ma machine est en 64bits. De plus je crois que la 2.0.6 ne fonctionne pas sous 32bits.

J'ai donc refait le lien avec ce chemin, mais DT n'a pas retrouvé la correction d'objectifs. J'avais un "sens interdit" en me demandant de ré installer les paquets manquants lensfun 0.2.8, ce que j'ai fait et je crois que je vais attendre sagement que le PPA s'appuie sur la 0.3.2. Dommage!
Répondre
#65
Fin du jeux Smile Après avoir vérifier à nouveau le modèle ACM est sur master mais pas sur la branche 0.3.x donc pas dans la version 0.3.2. Il faudra attendre la prochaine version (0.4.x?) je suppose pour que le support ACM soit disponible.

Deux solutions possibles:

- attendre la prochaine version

- compiler lensfun depuis les sources sur la branche master
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#66
Je n'ai pas pu m’empêcher de tester...

- j'ai recompilé lensfun depuis les sources (master branch)

- j'ai recompilé darktable pour utiliser _lcps.xml (conversion d'un objectif en .lcp vers un modèle lensfun)

Et... ça fonctionne sans problème! La distorsion est appliquée et semble cohérente.

Alors, il n'y a plus qu'a attendre la sortie de la prochaine version de lensfun.
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#67
Merci à tous pour toutes ces informations et ......patience! (pour moi tout au moins).
Répondre
#68
Pour information le support acm sera dans la prochaine version majeure de lensfun donc 0.4.
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)