Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: YadutafCorrection des objectifs : reconnaissance du boîtier
#71
Le modification que je t'avais porposée : https://darktable.fr/forum/showthread.ph...917&page=2
Elle avait marché chez moi avec LensFun 0.2.8 mais je n'ose pas te la reproposer, Thierry ?
Répondre
#72
@pobry : ta réponse du 15/11 ne s'affichait pas jusqu'à ce que j'envoie mon message de ce matin. Pour y répondre malgré tout : ma version de DT venait du dépôt instable de Pascal de Bruijn puis j'ai fait ma nouvelle installation avec son dépôt stable.

Jean-Paul : je vais la relire et, peut-être, réessayer. Mais je ne suis pas sûr, même si cela fonctionne, que ce soit une solution viable sur une distribution archi-utilisée.
Thierry
Répondre
#73
Je suis désolé, je n'ai pas d'autre solution à te proposer : https://drive.google.com/file/d/1CNs4V72...sp=sharing
C'est le fichier que j'ai modifié et qui a marché avec la version 0.2.8.
Répondre
#74
Je vais allé mettre cela prudemment sur mon portable et voir ce que cela donne.

Concrètement, où places-tu ce fichier ? Dans ~/.local/share/lensfun/ je suppose ?
Thierry
Répondre
#75
Oui, dans le répertoire .local/share/lensfun ou le fichier peut y être mis sans passer en mode administrateur.S 'il n'existe pas, il faut que tu le crées.
Répondre
#76
C'est fait. Cela fonctionne donc cela me sauve, je vais pouvoir progresser. Ceci dit, il va absolument falloir trouver une solution pérenne sous Ubuntu pour pouvoir bénéficier facilement de la librairie lensfun la plus récente avec ses mises à jour.

Cela doit même être très frustrant pour ceux qui font l'effort de caractériser des objectifs de devoir attendre deux ans, peut-être plus, pour voir leur travail bénéficier à tout le monde. Personnellement, je voudrais bien m'occuper du 100-400 Leica, par exemple, mais cela me refroidit un peu.
Thierry
Répondre
#77
Bonne nouvelle, Thierry. Tu peux regarder là s'il y a des correctif : https://github.com/lensfun/lensfun/tree/master/data/db
Répondre
#78
Est-ce ce fichier que tu as utilisé pour faire celui que tu m'as proposé et qui fonctionne ?
Thierry
Répondre
#79
Oui, j'ai pu le .rw2 que tu m'a envoyé du Gx8. Sur le lien que je t'ai donné, tu vois les dernières mises à jour.
Répondre
#80
(19-11-17, 10:15)Yaduta a écrit : Je suis donc aujourd'hui revenu à une installation neuve Linux + Darktable 2.2.5 stable + Lensfun 0.2.8 ce qui est, j'ose le dire, ridicule et je n'arrive pas à faire reconnaître une librairie lensfun plus récente par DT alors que Ubuntu Xenia propose 0.3.2 dans ses dépôts. Je ne sais pas ce qui m'échappe. C'est un problème prioritaire pour moi.

Concernant la version de Lensfun, c'est tout à fait normal, car la version 2.2.5 de DT ne fonctionne qu'avec cette version. La prochaine (2.4), devrait utiliser la version 0.3.2

Ceci dit il est possible de contourner la difficulté en copiant les fichiers de la BdD de Lensfun 0.3.2 qui t'intéressent vers l'emplacement des fichiers de la 0.2.8 et de modifier les entête de fichiers pour qui'il correspondent à la valeur de la 0.2.8.
Mes photos : jpverrue.fr
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)