Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: temperdu[Résolu] Correction d'objectifs pour un appareil avec un support de base
#21
Oui, j'ai pu récupéré les fichiers et j'ai été doublé par Pascal. Big Grin
J'allais m'y mettre ! Si ça marche chez toi, tu pourras mettre le titre du premier post [Résolu].
Répondre
#22
(09-02-18, 09:43)pascal a écrit : Ça marche pour moi.

Ton boitier est reconnu chez moi en plaçant compact-canon.xml dans ~/.local/share/lensfun/

Et en modifiant version:

Code :
<lensdatabase version="1">
Merci Pascal pour les tests, mais pour moi ça ne marche toujours pas. J'ai toujours les bords de l'objectif visibles sur le fichier Raw. Le fichier exif m'indique que je suis en focale 9mm ! Et ma configuration est la même : même emplacement de fichier, même version. C'est comme si DT ne lisait pas ce fichier. Et comme je l'écrivais, je n'ai toujours aucun appareil Canon de la gamme Powershot dans la liste des boitiers reconnus.
Répondre
#23
Tu as quelle version de lensfun? J'ai la 0.3.2.
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#24
(09-02-18, 10:32)pascal a écrit : Tu as quelle version de lensfun? J'ai la 0.3.2.

Alors justement, ça nous fait revenir à mon premier message qui disait en gros que j'avais bien un répertoire lensfun dans /usr/share mais ne contenant que des fichiers xml. Et que donc la commande lensfun-update-data ne donnait rien. Donc je ne peux pas te dire quelle version de lensfun est installée. La dernière version sur Github est bien la 0.3.2. Mais dans ce dossier, il y a des librairies, des outils, etc...

En gros, dans ton dossier /usr/share/lensfun il y a sûrement autre chose que des fichiers xml ?

Christian
Répondre
#25
Dans /usr/share/lensfun/ j'ai un répertoire nommé version_1 et dans ce dossier j'ai les fichiers xml.

Mais c'est que je suis en 0.3.2 de lensfun. Tu dois avoir une version plus ancienne.

Je ne sais pas avec Mint, est-ce qu'il y a un outil "apt" (debian) ?

Si oui, que donne les commandes suivantes:


Code :
apt-cache policy liblensfun
apt-cache policy liblensfun0
apt-cache policy liblensfun1
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#26
Je viens de télécharger compact-canon.xml, je n'ai pas de définition pour le PowerShoot G5 X seulement le G5. J'ai téléchargé la dernière version sur le site LensFun et aussi sur le ppa de Pascal de Bruijn ou j'ai extrait les bases de données.
Pour en revenir au fichier dans /usr/share/lensfun, voilà le début :
Code :
<lensdatabase>
   <camera>
       <maker>Canon</maker>
       <model>Canon PowerShot Pro1</model>
       <model lang="en">PowerShot Pro1</model>
       <mount>canonPro1</mount>
       <cropfactor>3.933</cropfactor>
   </camera>
   <camera>
       <maker>Canon</maker>
       <model>Canon PowerShot Pro70</model>
       <model lang="en">PowerShot Pro70</model>
       <mount>canonPro70</mount>
       <cropfactor>5.47</cropfactor>
   </camera>
Donc il faudrait modifier le fichier dans ce sens.
Pascal tu as trouvé ou le fichier compact-canon.xml  qui fonctionne ?
Répondre
#27
Dans l'archive de chris68. Le PowerShot G5 X est bien présent dans ce fichier.
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#28
J'avais pas vu le fichier de définition Canon. Je l'ai modifié, le boîtier est reconnu mais pas l'objectif. Il ne semble qu'il n'y a pas d'objectif défini pour le G5 X. Il faut voir si le G5 X à le même objectif d'un autre compact caractérisé dans le fichier.
Répondre
#29
Moi l'objectif est reconnu et j'ai même une belle correction d'objectif appliquée!
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#30
(09-02-18, 11:57)pascal a écrit : Dans /usr/share/lensfun/ j'ai un répertoire nommé version_1 et dans ce dossier j'ai les fichiers xml.

Mais c'est que je suis en 0.3.2 de lensfun. Tu dois avoir une version plus ancienne.

Je ne sais pas avec Mint, est-ce qu'il y a un outil "apt" (debian) ?

Si oui, que donne les commandes suivantes:


Code :
apt-cache policy liblensfun
apt-cache policy liblensfun0
apt-cache policy liblensfun1
Mes fichiers xml sont à la racine du dossier liblensfun et c'est tout ce qu'il contient. Je suis sur Ubuntu Gnome et j'ai bien l'outil apt. Voici les retours des commandes :

apt-cache policy liblensfunImpossible de trouver le paquet liblensfun

apt-cache policy liblensfun0 : liblensfun0:

  Installé : 0.2.8-3pmjdebruijn3~xenial

  Candidat : 0.2.8-3pmjdebruijn3~xenial

 Table de version :

 *** 0.2.8-3pmjdebruijn3~xenial 500

        500 http://ppa.launchpad.net/pmjdebruijn/dar...ase/ubuntu xenial/main amd64 Packages

        100 /var/lib/dpkg/status

     0.2.8-3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages

apt-cache policy liblensfun1 : Impossible de trouver le paquet liblensfun1

Dans Synaptic, je n'ai que la possibilité d'installer la librairie liblensfun0, ce qui est déjà le cas.

Bon week-end à toi Pascal

(09-02-18, 14:13)jpg54 a écrit : J'avais pas vu le fichier de définition Canon. Je l'ai modifié, le boîtier est reconnu mais pas l'objectif. Il ne semble qu'il n'y a pas d'objectif défini pour le G5 X. Il faut voir si le G5 X à le même objectif d'un autre compact caractérisé dans le fichier.
Oui jpg54, le G5 X a les mêmes caractéristiques (capteur et objectif) que le G7 X. Seul le processeur passe au Digic 7

Bon week-end à toi Smile
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)