Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: aurelienpierretest darktable 2.6.2 / OpenCL Windows
#21
Bon, c'est "nimbe", darktable WinDows 2.6.2 fonctionne très bien. Je sais pas pourquoi, j'avais RGB Rec709 linéaire comme profil écran. Parfois, je me mettrais des baffes. Angry

Avec mon Dell G3 : https://www.ldlc.com/fiche/PB00254607.html
Sous W10 : export d'un NEF avec dématriçage Amaze 2 passes et filmique : 4" avec ou sans OpenCL ; avec un RAF dématriçage Markesteijn 3 passes, filmique et balance de couleurs : 5" avec ou sans OpenCL.
Temps Identiques sous OpenSUSE sans OpenCL. Purée, j'ai plus l'OpenCl sous OpenSUSE. Grrrrrrrrrrrrrrrrrrrrrrrrrrrrrr
Répondre
#22
windows 8.1
intel core i7-4770 3.40 GHz
RAM 8Go
OpenCL activé défaut, puis GPU multiples et GPU très rapide
filmique préréglage 12 EV exterieur

Tests faits avec le fichier darktablerc modifié et le fichier d'origine : pas de problème.
Merci
Alain Wasniewski
Windows 8.1-darktable 2.6.2
Canon 650 D. Canon 18-135 mm. Canon macro 100 mm
Répondre
#23
Bonjour.

J'ai testé rapidement la version 2.6.2 sur

ACER Aspire E15
Windows 10
Intel Core i5-7200U 2.5 GHz - 4GB DDR4
NVDIA GeForce 940MX
OpenCL activé

Tout semble fonctionner parfaitement.

Et merci à tous ceux qui se démènent pour faire vivre darktable et son forum.
Je n'ai pas, loin de là, les compétences théoriques de certains, mais j'essaie de suivre.
Répondre
#24
Voici les résultats de mes tests sur mes 2 PC.
  • Tout semble fonctionner parfaitement. En particulier, le problème du tassage de l'histogramme à gauche avec l'option "préservation de la chrominance" de filmique est résolu quelles que soient les valeurs des paramètres "activation OpenCL" et "Profil de planification OpenCL"
  • Concernant les performances je ne vois aucune différence perceptible entre les différentes valeurs des mêmes paramètres. Il s'agit évidemment d'un ressenti empirique, pas d'un benchmark scientifique.
A toutes fins utiles les config de mes PC :

Portable HP Laptop15*db0xxx LAPTOP-IIV3T793 :
- darktable 2.6.2
- Version de Windows 10 Famille 64 bits 1803 – version 17134.648
- 4 GB RAM
- Carte graphique built-in AMD Radeon R3 Graphics
- Type de processeur : AMD A4-9125 RADEON R3 4 cores 2.30 Ghz
- Anti-virus installé Avast


Portable ASUS XJ72 :
- darktable 2.6.2
- Version de Windows 10 Famille 64 bits 1803 – version 17134.648
- 4 GB RAM
- Carte graphique built-in AMD Mobility Radeon HD 5000 series
- Type de processeur : Intel core i3 CPU M 350 2,27 GHz
- Anti-virus installé Mc Affee
Amicalement,

Georges

Version 2.6.2 sous Windows
Boitier Fujifilm X-T3




Répondre
#25
Et encore un pour moi, à la pose de midi sur une station de calculs entre deux dimensionnements de structure.
Onc... ohhhh avec 80 cm de diagonale d'écran le zoom devient presque accessoire.
Sinon RAS, finger in the nose

Xeon E3-1230 V6 3,50 GHz
Nvidia Quatro P1000
Répondre
#26
Sur mon portable équipé d'une double carte Intel et Nvidia (OpenCL activé) , pas de problème. Mais je ne l'utilise que depuis 24h...
Répondre
#27
J'ai d'autres soucis que des couleurs désaturées.
J'essaie DT 2.6.2 sous Windows 10 à jour, avec les drivers derniers Nvidia 430.64 téléchargés sur le site de Nvidia. Le panneau de configuration Nvidia est réglé sur "Processeur Nvidia Haute performances". La commande darktable-cltest.exe ne retourne que des succès et se termine par :

Code :
3.331822 [opencl_init] kernel loading time: 1.0691
3.333816 [opencl_init] OpenCL successfully initialized.
3.336808 [opencl_init] here are the internal numbers and names of OpenCL devices available to darktable:
3.342791 [opencl_init] 0 'Intel(R) UHD Graphics 620'
3.345784 [opencl_init] 1 'GeForce MX150'
3.347778 [opencl_init] FINALLY: opencl is AVAILABLE on this system.

J'ai donc 2 cartes graphiques : un Intel intégrée (lente) et une Nvidia dédiée (plus rapide). Mon problème est que DT est plutôt lent et pénible à utiliser mais qu'il n'emploie purtant pas toutes les ressources disponibles. DT persiste à employer le GPU intégré à fond, et le dédié de manière marginale. J'ai fait une petite démo :


(en réalité C1P est parfaitement fluide sans aucun retard : le vidéo donne l'impression que ça laggue mais ec n'est pas le cas)

J'ai bien coché dans les options l'activation d'OpenGL, et j'ai essayé avec toutes les options disponibles juste en dessous dans le menu déroulant. Avec l'option "default", j'ai en plus essayé de changer de plein de manières l'option "opencl_device_priority" dans le "darktablerc" (en me fondant sur https://www.darktable.org/usermanual/en/...vices.html). Ca a parfois désactivé complètement le GPU Nvidia (ce qui montre au moins que le fichier que je modifie est le bon), mais je ne parviens pas à faire travailler le GPU Nvidia au delà de 7-8%. Pourtant, j'ai essayé avec des trucs que je pensais vraiment radicaux comme 

Code :
opencl_device_priority=!Intel(R) UHD Graphics 620,+GeForce MX150/!Intel(R) UHD Graphics 620,+GeForce MX150/!Intel(R) UHD Graphics 620,+GeForce MX150/!Intel(R) UHD Graphics 620,+GeForce MX150

(pour tout : interdiction du Intel et forçage du Nvidia) mais rien n'y fait.

Capture One Pro exploite un peu plus le processeur dédié mais pas à fond non plus. Ceci dit, les autres processeurs ne sont jamais à fond non plus et tout est instantané, donc je mets plutôt ça sur le compte de ce que C1P a de la marge. Avec DT, c'est plus gênant parce que c'est lent et avec de longs "working" et les processeurs qui chauffent, sauf le plus rapide  Undecided


J'avais posté sur Pixl.us mais sans succès, personne ne me répondant vraiment.
Répondre
#28
(23-05-19, 09:26)temperdu a écrit : J'ai d'autres soucis que des couleurs désaturées.
J'essaie DT 2.6.2 sous Windows 10 à jour, avec les drivers derniers Nvidia 430.64 téléchargés sur le site de Nvidia. Le panneau de configuration Nvidia est réglé sur "Processeur Nvidia Haute performances". La commande darktable-cltest.exe ne retourne que des succès et se termine par :

Code :
3.331822 [opencl_init] kernel loading time: 1.0691
3.333816 [opencl_init] OpenCL successfully initialized.
3.336808 [opencl_init] here are the internal numbers and names of OpenCL devices available to darktable:
3.342791 [opencl_init] 0 'Intel(R) UHD Graphics 620'
3.345784 [opencl_init] 1 'GeForce MX150'
3.347778 [opencl_init] FINALLY: opencl is AVAILABLE on this system.

J'ai donc 2 cartes graphiques : un Intel intégrée (lente) et une Nvidia dédiée (plus rapide). Mon problème est que DT est plutôt lent et pénible à utiliser mais qu'il n'emploie purtant pas toutes les ressources disponibles. DT persiste à employer le GPU intégré à fond, et le dédié de manière marginale. J'ai fait une petite démo :


(en réalité C1P est parfaitement fluide sans aucun retard : le vidéo donne l'impression que ça laggue mais ec n'est pas le cas)

J'ai bien coché dans les options l'activation d'OpenGL, et j'ai essayé avec toutes les options disponibles juste en dessous dans le menu déroulant. Avec l'option "default", j'ai en plus essayé de changer de plein de manières l'option "opencl_device_priority" dans le "darktablerc" (en me fondant sur https://www.darktable.org/usermanual/en/...vices.html). Ca a parfois désactivé complètement le GPU Nvidia (ce qui montre au moins que le fichier que je modifie est le bon), mais je ne parviens pas à faire travailler le GPU Nvidia au delà de 7-8%. Pourtant, j'ai essayé avec des trucs que je pensais vraiment radicaux comme 

Code :
opencl_device_priority=!Intel(R) UHD Graphics 620,+GeForce MX150/!Intel(R) UHD Graphics 620,+GeForce MX150/!Intel(R) UHD Graphics 620,+GeForce MX150/!Intel(R) UHD Graphics 620,+GeForce MX150

(pour tout : interdiction du Intel et forçage du Nvidia) mais rien n'y fait.

Capture One Pro exploite un peu plus le processeur dédié mais pas à fond non plus. Ceci dit, les autres processeurs ne sont jamais à fond non plus et tout est instantané, donc je mets plutôt ça sur le compte de ce que C1P a de la marge. Avec DT, c'est plus gênant parce que c'est lent et avec de longs "working" et les processeurs qui chauffent, sauf le plus rapide  Undecided


J'avais posté sur Pixl.us mais sans succès, personne ne me répondant vraiment.

Bonjour,
peut-être en désactivant le gpu intégré dans le bios pur que seule la carte nvidia fonctionne ...
Windows 10 Pro 1903 - dt 2.7 dev
Répondre
#29
[quote pid='32989' dateline='1558612604']
Bonjour,
peut-être en désactivant le gpu intégré dans le bios pur que seule la carte nvidia fonctionne ...
[/quote]

Oui c'est sûr. Mais j'aurais souhaité éviter. Le Nvidia MX150 utilise beaucoup plus d'énergie que le GPU intégré, avec du coup une autonomie largement réduite. Je suis content d'avoir le GPU intégré pour internet, la bureautique etc.

DT a l'air d'être prévu pour exploiter plusieurs cartes graphiques mais sous Windows, je ne parviens pas à exploiter la plus puissante à plus de 10%.
Répondre
#30
(23-05-19, 09:26)temperdu a écrit : Mon problème est que DT est plutôt lent et pénible à utiliser mais qu'il n'emploie pourtant pas toutes les ressources disponibles. DT persiste à employer le GPU intégré à fond, et le dédié de manière marginale. J'ai fait une petite démo :

Hum,

M'enfin c'est complètement oublier que ton PC possède aussi un autre processeur que ceux dédiés au graphisme, image ou vidéo à afficher à l'écran.
En grande partie une multitude de modules de dt avant de pouvoir t'afficher à l'écran le résultat de tes actions effectuent des quantités de calculs et le processeur principal est largement sollicité à ce stade lui aussi.
Par contre quant il s'agit de rafraîchir l'écran sur un benchmark vidéo comme à la fin de ta démonstration, là il et clair que ta nvidia est mise à contribution et monte au taquet.

Par exemple, ouvre une ou plusieurs instances du module réduction de bruit, met le rayon à 30 et constate quel processeur va travailler le plus avant que le résultat ne s'affiche à l'écran.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)